Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomePublicationsRegisterLog in

Share | 
 

 Mod Bug has bit again...

View previous topic View next topic Go down 
AuthorMessage
CanadianCruiser
Member
avatar


PostSubject: Mod Bug has bit again...   Fri Jul 18, 2014 3:36 pm

Well gents, the bug has bit again...

Over the summer I've came up with a few Ideas...

1. red lighting along the fuel tank illuminating the engine and in the wheel wells to give it that possessed look.
2. Stage 3 Jetting (dumping the stock boxes and K&N drop in's for Clamp on's)
3. Big City Thunder baffles.
4. still tossing the idea but thinking of Adding a Hypercharger (obviously just for show on the vz800)
5. possibly some flaming skull decals on the tank or paintjob.

As you probably guess going for the "Ghost Rider" look here.  Entered a local show here and was told I look like the rider so figured I'd go with it..

And the Final Mod, wouldn't be the rider without it..Flames! 

Been searching the web and all the kits temporarily kill the spark from the plugs filling the cylinders with fuel then push it out and it's ignited in the pipes..I'm not a fan of these and the fuel washes the oil away in the cylinder and has a potential of contaminating the oil... Not good for the engine.. so I'm going Old School on this one...

When I was a kid my dad had a hot rod and showed me the trick to do exhaust flames with a manual Choke and carb system (if I'm not happy with this I'll add a line from the tank to the exhaust to inject fuel).  Just need to add the spark in the exhaust.. In his day he used Spark Plugs... Which is too bulk and not neat looking... I'm going with BBQ Igniters...

Pics to come as I start this project.
Back to top Go down
simbo
.. Mechanical Tart .. .. Site Moderator ..
avatar


PostSubject: Re: Mod Bug has bit again...   Fri Jul 18, 2014 5:17 pm

Bloody hell! I'm looking forward to following this thread!    Sounds good CC  
Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
avatar


PostSubject: Re: Mod Bug has bit again...   Fri Jul 18, 2014 9:40 pm

Also looking forward to it.  
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Sat Jul 19, 2014 2:03 am

Almost have everything to do start... just waiting on the K&N's.....
Back to top Go down
OldManYam
Very Valued VIP Member
avatar


PostSubject: Re: Mod Bug has bit again...   Sat Jul 19, 2014 9:14 am

Yep ... its sounding good .... just waiting to see those pics !
Back to top Go down
captain crash
Mentally Deficient lunatic ..... & ..... Site Moderator
avatar


PostSubject: Re: Mod Bug has bit again...   Sat Jul 19, 2014 10:00 am

Good on ya, sounds ace  
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Wed Jul 23, 2014 3:34 am

well, started the mods, today... got the new jets in,, Front-42.5P 135M Rear-47.5P 145M
RA0470 & RU0680 K&N clampons...Also going to relocate the Crankcase vent... using a Universal K&N filter...
Also put in the Big City Thunder baffles, Man does it sound awesome... I'll have to upload a vid to youtube once I get it back together...
Still to do, Lighting around tank, and figure out igniters for pipe flame... got some pics of my idea..



Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
avatar


PostSubject: Re: Mod Bug has bit again...   Wed Jul 23, 2014 9:53 am

Oh this is great & I will look forward to the video as well.  oyili
Back to top Go down
simbo
.. Mechanical Tart .. .. Site Moderator ..
avatar


PostSubject: Re: Mod Bug has bit again...   Wed Jul 23, 2014 9:30 pm

Looking forward to the video to hear those baffles  
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Thu Jul 24, 2014 3:01 am

well, was off to a slow start today... my grandson decided he wanted to help and relocated my tools... ambitious for an 18 month old lol... but after I gathered everything up I managed to get the Crankcase hose and filter mounted...

Used a K&N crankcase filter I had from my car... some 5/8th hose and a 90 degree elbow... fabricated the mounting bracket and mounted the filter by the choke...

Hoping tomorrow to set the carbs and get the red lights along the tank in... Trying to decide if I want them on a toggle or wired into the ignition... suggestions?



Back to top Go down
peardrop3
Very Valued VIP Member
avatar


PostSubject: Re: Mod Bug has bit again...   Thu Jul 24, 2014 6:43 pm

Probably better with a switch cos if the police get snotty then you can switch them off & say to them they must have been mistaken....
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Thu Jul 24, 2014 9:57 pm

yeah wound up going with a switch..
Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
avatar


PostSubject: Re: Mod Bug has bit again...   Fri Jul 25, 2014 9:43 am

Good idea to have a switch.
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Mon Jul 28, 2014 3:10 pm

well routing the breather tube over the engine wasn't a good idea... moisture rolls back into the crankcase and the tube is pressing down on the choke cable causing the plunger not to return into the seat...

going to route it down and along the bottom of the engine... also going to add a "T" fitting so I can have a drain tube...
Back to top Go down
simbo
.. Mechanical Tart .. .. Site Moderator ..
avatar


PostSubject: Re: Mod Bug has bit again...   Mon Jul 28, 2014 5:13 pm

Good idea for the drain tube CC  :good i:
Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Tue Dec 09, 2014 2:11 am

So little update here... pretty much scrapped the whole layout and redoing...when it's back together I'll start a before and after thread..
Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
avatar


PostSubject: Re: Mod Bug has bit again...   Tue Dec 09, 2014 8:21 pm

What you write is always worth reading I'll look forward to it.
Back to top Go down
simbo
.. Mechanical Tart .. .. Site Moderator ..
avatar


PostSubject: Re: Mod Bug has bit again...   Tue Dec 09, 2014 10:16 pm

Mr Intruder wrote:
What you write is always worth reading I'll look forward to it.

Back to top Go down
CanadianCruiser
Member
avatar


PostSubject: Re: Mod Bug has bit again...   Wed Dec 10, 2014 1:00 am

Thanks guys! wagg
Back to top Go down
Sponsored content




PostSubject: Re: Mod Bug has bit again...   

Back to top Go down
 
Mod Bug has bit again...
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Aftermarkets & Modifications-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» vs800 bobber build
by nicz Thu Dec 14, 2017 7:22 pm

» Hello
by EvoChris Mon Dec 11, 2017 2:58 pm

» VZ800 rear shocks
by Saxon Thu Dec 07, 2017 6:49 am

» Clutch advice
by bigmal Wed Dec 06, 2017 7:26 pm

» Vx800 stator plate sizes and swapping one for another
by mullet Mon Dec 04, 2017 11:12 pm

» Some of my toys....
by ardie Thu Nov 30, 2017 2:25 pm

» Hi All, from Sunny Kent :)
by EvoChris Mon Nov 27, 2017 12:19 pm

» Rear Crash bars
by KeithW Sat Nov 25, 2017 1:42 pm

» 7/8 to 1" switches ?
by grumpy grandad Wed Nov 22, 2017 5:07 pm

» Ola from down south....
by stingray Fri Nov 17, 2017 9:04 pm

» Dual headlights
by Saxon Fri Nov 17, 2017 5:54 pm

» Exhaust and air filter, no tuner...
by Dj_Star Thu Nov 16, 2017 7:08 pm

» Hello from North Herts
by v-twin Wed Nov 15, 2017 6:48 am

» Indicator issues
by G.Terence Fri Nov 10, 2017 2:15 pm

» vs 750 oil leak ?
by grumpy grandad Mon Nov 06, 2017 7:15 pm

» Greetings from the South Coast
by peardrop3 Sun Nov 05, 2017 2:33 pm

» vs750 fuel pump
by grumpy grandad Sat Nov 04, 2017 8:44 pm

» Hello
by bigmal Sat Nov 04, 2017 10:46 am

» C800 from Italy
by Big Al Fri Nov 03, 2017 11:05 pm

» Stoopid, I know, but...
by OldManYam Tue Oct 31, 2017 7:59 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password