Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomePublicationsRegisterLog in

Share | 
 

 Indicators and LED bulbs.

View previous topic View next topic Go down 
AuthorMessage
Billyz
Member
avatar


PostSubject: Indicators and LED bulbs.   Mon Sep 12, 2016 1:06 pm

hi everyone, long, long time since I've been on here but have spent some time recovering from my second triple heart bypass, I can tell you it was a somewhat long and torturous path! Enough of that stuff. I have recently reintroduced myself to my Volusia trike and am the proud owner of a new MOT. I have been fiddling around with the trike recently and wanted to change out my standard indicator bulbs for LED bulbs. All went well but for some reason the front left hand indicator, whilst happy to flash an ordinary bulb refuses to power up an LED. I have tried the bulb in the other sockets and it works fine. Is this just a connection issue with this particular indicator or am I missing something? Any advice appreciated. Cheers
Back to top Go down
peardrop3
Very Valued VIP Member
avatar


PostSubject: Re: Indicators and LED bulbs.   Mon Sep 12, 2016 6:06 pm

I'd check out all the connectors that side Bill but do note that you'll need an LED compatable indicator flasher unit to make the LED's work correctly.
Glad to hear you are feeling better after your illness as well!
Back to top Go down
Billyz
Member
avatar


PostSubject: Re: Indicators and LED bulbs.   Mon Sep 12, 2016 7:06 pm

Thanks for the kind words Pete.
I've already changed out the flasher unit so not that I think. I must have spent a couple of hours on the flipping thing today but try as I might I cannot find the fault. Thought perhaps I might just replace the whole front units with something off of E bay, lots of LED units on there from about a Fiver to seventy or eighty pounds, if anybody has any recommendations let me know.
Back to top Go down
alfie92
Very Valued VIP Member
avatar


PostSubject: Re: Indicators and LED bulbs.   Mon Sep 12, 2016 9:44 pm

Hi Pete hope you get over your op, as regards to your leds you may need a diode to change the direction of the current, not sure, I know that the warning light does not always work on one side when fitting leds, lets hope someone pops up with the answer.
Back to top Go down
hmac
Member
avatar


PostSubject: Re: Indicators and LED bulbs.   Mon Sep 12, 2016 10:40 pm

Sounds like a polarity issue. Led bulbs have a positive and negative side and wont work if they are connected wrong way round, try swapping round the wires going to that indicator.
Back to top Go down
Sponsored content




PostSubject: Re: Indicators and LED bulbs.   

Back to top Go down
 
Indicators and LED bulbs.
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» 1985 K100RT instrument cluster with 4,567 miles
» Park Lights As Indicators
» Indicators Not Working
» Write-Up: Replacing bulbs in a G-Body Riviera head unit
» Has anyone replaced burned out bulbs in their HVAC control?

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Electrical Modifications, Help & Information.-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» vs800 bobber build
by nicz Thu Dec 14, 2017 7:22 pm

» Hello
by EvoChris Mon Dec 11, 2017 2:58 pm

» VZ800 rear shocks
by Saxon Thu Dec 07, 2017 6:49 am

» Clutch advice
by bigmal Wed Dec 06, 2017 7:26 pm

» Vx800 stator plate sizes and swapping one for another
by mullet Mon Dec 04, 2017 11:12 pm

» Some of my toys....
by ardie Thu Nov 30, 2017 2:25 pm

» Hi All, from Sunny Kent :)
by EvoChris Mon Nov 27, 2017 12:19 pm

» Rear Crash bars
by KeithW Sat Nov 25, 2017 1:42 pm

» 7/8 to 1" switches ?
by grumpy grandad Wed Nov 22, 2017 5:07 pm

» Ola from down south....
by stingray Fri Nov 17, 2017 9:04 pm

» Dual headlights
by Saxon Fri Nov 17, 2017 5:54 pm

» Exhaust and air filter, no tuner...
by Dj_Star Thu Nov 16, 2017 7:08 pm

» Hello from North Herts
by v-twin Wed Nov 15, 2017 6:48 am

» Indicator issues
by G.Terence Fri Nov 10, 2017 2:15 pm

» vs 750 oil leak ?
by grumpy grandad Mon Nov 06, 2017 7:15 pm

» Greetings from the South Coast
by peardrop3 Sun Nov 05, 2017 2:33 pm

» vs750 fuel pump
by grumpy grandad Sat Nov 04, 2017 8:44 pm

» Hello
by bigmal Sat Nov 04, 2017 10:46 am

» C800 from Italy
by Big Al Fri Nov 03, 2017 11:05 pm

» Stoopid, I know, but...
by OldManYam Tue Oct 31, 2017 7:59 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password