Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomePublicationsRegisterLog in

Share | 
 

 Indicator issues

View previous topic View next topic Go down 
AuthorMessage
Dj_Star
Member
avatar


PostSubject: Indicator issues   Mon Nov 06, 2017 5:04 pm

Getting to the point this driving me nuts. 

Bought new indicators and new cables as the last ones sheared the bracket. (Front only for the minute) 

I’ve just fitted them, but now the flash ones at normal rate then flash at high speed!?! 

Any ideas? Anyone help?? 

Please.... video available if it will help....!?!

Dj 
Back to top Go down
peardrop3
Very Valued VIP Member
avatar


PostSubject: Re: Indicator issues   Mon Nov 06, 2017 5:32 pm

Have you got bulbs fitted or LED's as the LED's will flash a lot quicker than bulbs ok.
Back to top Go down
Dj_Star
Member
avatar


PostSubject: Re: Indicator issues   Mon Nov 06, 2017 6:19 pm

Nope, bulbs all round.
Back to top Go down
v-twin
Valued VIP Member
avatar


PostSubject: Re: Indicator issues   Mon Nov 06, 2017 6:33 pm

Check the bulbs on the old & new ones and make sure they are the same wattage (21w I think is the norm).
Back to top Go down
Wiggo
Member
avatar


PostSubject: Re: Indicator issues   Wed Nov 08, 2017 2:28 pm

I can confirm there are some crappy cheap Chinese ones on Ebay and Amazon that ship with 10W bulbs and they will flash far too fast.
Back to top Go down
G.Terence
Member
avatar


PostSubject: Re: Indicator issues   Fri Nov 10, 2017 2:15 pm

Three things to check Bulb compatibility,ensure you have a very good earth contact and all contacts are firm and secure.

Terry
Back to top Go down
Sponsored content




PostSubject: Re: Indicator issues   

Back to top Go down
 
Indicator issues
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» I have a titleist stand bag with some issues.
» Ironstone is it an indicator?
» AutoSleeper Palermo issues
» TBM BACK ISSUES
» Help k100 lt engine issues

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Electrical Modifications, Help & Information.-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» Ola from down south....
by stingray Fri Nov 17, 2017 9:04 pm

» Dual headlights
by Saxon Fri Nov 17, 2017 5:54 pm

» Clutch advice
by OldManYam Thu Nov 16, 2017 10:19 pm

» Exhaust and air filter, no tuner...
by Dj_Star Thu Nov 16, 2017 7:08 pm

» Hello from North Herts
by v-twin Wed Nov 15, 2017 6:48 am

» Indicator issues
by G.Terence Fri Nov 10, 2017 2:15 pm

» vs 750 oil leak ?
by grumpy grandad Mon Nov 06, 2017 7:15 pm

» Greetings from the South Coast
by peardrop3 Sun Nov 05, 2017 2:33 pm

» vs750 fuel pump
by grumpy grandad Sat Nov 04, 2017 8:44 pm

» Hello
by bigmal Sat Nov 04, 2017 10:46 am

» C800 from Italy
by Big Al Fri Nov 03, 2017 11:05 pm

» Stoopid, I know, but...
by OldManYam Tue Oct 31, 2017 7:59 pm

» Powder coat wheels
by ardie Mon Oct 30, 2017 7:42 pm

» Hello again everyone!
by thepolack Sat Oct 28, 2017 4:13 pm

» the biggest rear tire / rim that fits on VX 800
by peardrop3 Sat Oct 28, 2017 1:46 pm

» VZ800 engine rebuild
by v-twin Sat Oct 28, 2017 9:36 am

» wiring harness & speedo-indicator
by RAnst4038 Sat Oct 28, 2017 2:38 am

» 1998 VS800 65,000mi Clutch Start
by RAnst4038 Wed Oct 25, 2017 1:36 am

» Clutch problem
by chilterns Tue Oct 24, 2017 3:53 pm

» Hey, Rick from York Pa
by ardie Tue Oct 24, 2017 3:45 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password