Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomePublicationsRegisterLog in

Share
 

 Speedometer problem

Go down 
AuthorMessage
ASantos
Prospect



Speedometer problem Empty
PostSubject: Speedometer problem   Speedometer problem Icon_minitimeThu Dec 13, 2018 1:35 pm

Hi guys,
Does anyone knows if its possible to fix this?
Theres some characters missing on display...

ThanksSpeedometer problem 20181210
Back to top Go down
peardrop3
Very Valued VIP Member
peardrop3


Speedometer problem Empty
PostSubject: Re: Speedometer problem   Speedometer problem Icon_minitimeSat Dec 15, 2018 12:13 pm

You may find it has moisture in the rear so take the assembly off & put it somewhere warm to dry or if you know for sure it has not been wet then try some vaseline(petroleum jelly) on the connector block after using some electrical cleaner & see if it comes back? If not it may mean it needs swapping for a working one or even a new one sorry. Maybe someone else on here has another thought though ok?
Back to top Go down
 
Speedometer problem
Back to top 
Page 1 of 1
 Similar topics
-
» Problem with Power Cord
» How can i fix a priming problem?
» Snapper Transaxle Problem?
» PS3 Master account problem
» SD 2100 switches off by itself... battery problem?

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Electrical Modifications, Help & Information.-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» First post from Arnold in Idaho
Speedometer problem Icon_minitimeby stingray Today at 7:06 pm

» register logon - C'mon in and say hello - I think
Speedometer problem Icon_minitimeby stingray Today at 7:03 pm

» SAYING HELLO FROM WINNIPEG, MANITOBA
Speedometer problem Icon_minitimeby Takkyu Fri Jun 21, 2019 5:33 pm

» Hello! This is Ed from Wash.,DC
Speedometer problem Icon_minitimeby Takkyu Fri Jun 21, 2019 5:32 pm

» Hiyas
Speedometer problem Icon_minitimeby Takkyu Fri Jun 21, 2019 5:31 pm

» Newbie
Speedometer problem Icon_minitimeby peardrop3 Fri Jun 21, 2019 5:30 pm

» Hello
Speedometer problem Icon_minitimeby Takkyu Fri Jun 21, 2019 5:29 pm

» Ratchet noise from under tank.
Speedometer problem Icon_minitimeby goshhub Fri Jun 14, 2019 11:39 pm

» First Time Ever Saw Mr Green
Speedometer problem Icon_minitimeby ArnoldinIdaho Fri Jun 14, 2019 9:51 pm

» Hi new here...
Speedometer problem Icon_minitimeby OldManYam Tue Jun 04, 2019 10:10 pm

» Hello from Bulgaria
Speedometer problem Icon_minitimeby OldManYam Tue Jun 04, 2019 10:08 pm

» Hello from Ipswich
Speedometer problem Icon_minitimeby OldManYam Tue Jun 04, 2019 10:07 pm

» VZ800 Charging issue
Speedometer problem Icon_minitimeby peardrop3 Mon Jun 03, 2019 2:03 pm

» Hello from Calgary Alberta CANADA
Speedometer problem Icon_minitimeby peardrop3 Sun Jun 02, 2019 4:55 pm

» Hi from South Wales
Speedometer problem Icon_minitimeby Takkyu Mon May 27, 2019 3:35 pm

» Tailbone pain after 100 miles on stock seat.
Speedometer problem Icon_minitimeby ardie Sun May 26, 2019 6:54 pm

» My 2013 M50
Speedometer problem Icon_minitimeby ardie Sun May 26, 2019 6:50 pm

» Brake lever!
Speedometer problem Icon_minitimeby Shrek Sun May 26, 2019 1:45 pm

» Brake lever!
Speedometer problem Icon_minitimeby Shrek Sun May 26, 2019 1:29 pm

» Hi from Calgary, Alberta, Canada! (2000 Maurader VZ800)
Speedometer problem Icon_minitimeby Takkyu Sat May 25, 2019 8:36 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password