Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.
Suzuki 800 Intruder Club & Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomeRegisterLog in

 

 Horn Not working on M800

Go down 
AuthorMessage
chrisalang
Newbie
chrisalang


Horn Not working on M800 Empty
PostSubject: Horn Not working on M800   Horn Not working on M800 Icon_minitimeMon Mar 19, 2012 10:40 am

The horn on my Intruder has stopped working. I have removed it and tested and it is fine so it is the wiring. The horn push switch appears to be working with 12V at input and when pushed 12V at the output. On the connections to the horn there is a constant 12V but no earth. Is the horn activated via earth activation using a relay? If so where is the relay? I will change the stock horn for a better one but I need to get the wiring working first. Any help appreciated.
Back to top Go down
captain crash
Mentally Deficient lunatic ..... & ..... Site Moderator
captain crash


Horn Not working on M800 Empty
PostSubject: Re: Horn Not working on M800   Horn Not working on M800 Icon_minitimeMon Mar 19, 2012 12:05 pm

Have you checked the continuity of the earth. The horn does not have a relay as it doesnt pull hardly any power
There is a wiring diagramme for your bike in the pdf manual in the maintenance section, hope that helps Horn Not working on M800 184121345

PS. Pop in to the C'mon in and say hello section to introduce yourself as the site rules are that members must introduce themselves before posting. If an admin spots this thread without an introduction it will be deleted (I have seen that happen).
Back to top Go down
ippikin
Member
ippikin


Horn Not working on M800 Empty
PostSubject: Re: Horn Not working on M800   Horn Not working on M800 Icon_minitimeMon Mar 19, 2012 2:16 pm

This happened to me.... the horn just stopped working. If there is continuity at the switch (check with a mulitmeter) then I would ditch the stock horn (as it's so pathetic) and either fit a Stebel Nautilus as per Mr Intruder, see LINK. Or you could do what I did and fit a new horn under the R side panel. See LINK
Back to top Go down
Sponsored content




Horn Not working on M800 Empty
PostSubject: Re: Horn Not working on M800   Horn Not working on M800 Icon_minitime

Back to top Go down
 
Horn Not working on M800
Back to top 
Page 1 of 1
 Similar topics
-
» Transaxle stopped working out of nowhere
» Working overtime again
» Maxxis Big Horn Tire Pressure
» How has working on your core helped your running
» Big Horn Tires

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Electrical Modifications, Help & Information.-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» Slammed Volusia - 2" lowering kit - video
Horn Not working on M800 Icon_minitimeby buzz5019 Thu Jul 09, 2020 9:37 pm

» VX800 exhaust advice
Horn Not working on M800 Icon_minitimeby oldmick Thu Jul 09, 2020 8:05 pm

» Hi everyone
Horn Not working on M800 Icon_minitimeby stingray Thu Jul 09, 2020 1:57 pm

» Suzuki C50/C800 valve adjustment procedure tips
Horn Not working on M800 Icon_minitimeby EazyDuz Wed Jul 08, 2020 10:42 pm

» Cooling fan troubles
Horn Not working on M800 Icon_minitimeby Dushmth88 Wed Jul 08, 2020 7:27 pm

» Debaffled and looking for end caps
Horn Not working on M800 Icon_minitimeby rehanpk Tue Jul 07, 2020 7:34 pm

» Tail light fuse blowing
Horn Not working on M800 Icon_minitimeby hmac Tue Jul 07, 2020 1:57 pm

» * Suzuki C800, De-badge *
Horn Not working on M800 Icon_minitimeby Badger Fri Jul 03, 2020 5:19 pm

» Single red and blue wire help
Horn Not working on M800 Icon_minitimeby ardie Tue Jun 30, 2020 5:55 pm

» New old guy
Horn Not working on M800 Icon_minitimeby ardie Tue Jun 30, 2020 5:46 pm

» Hi Suzuki drivers
Horn Not working on M800 Icon_minitimeby ardie Tue Jun 23, 2020 1:01 am

» Hello
Horn Not working on M800 Icon_minitimeby Badger Sun Jun 21, 2020 10:51 am

» Lft side swing arm cover - decoration or functional?
Horn Not working on M800 Icon_minitimeby Badger Sat Jun 20, 2020 12:48 pm

» Advice on carrier needed.
Horn Not working on M800 Icon_minitimeby Holstein Thu Jun 18, 2020 6:50 pm

» Helllo
Horn Not working on M800 Icon_minitimeby Badger Thu Jun 18, 2020 10:52 am

» Bad vibrations
Horn Not working on M800 Icon_minitimeby Badger Tue Jun 16, 2020 1:31 pm

» 50/50 vinegar flush.
Horn Not working on M800 Icon_minitimeby Badger Mon Jun 15, 2020 2:41 pm

» Vz800 speedometer
Horn Not working on M800 Icon_minitimeby Mpiercy94 Sun Jun 14, 2020 11:43 am

» Hello
Horn Not working on M800 Icon_minitimeby Pygsli Sat Jun 13, 2020 7:01 pm

» Front wheel gap?
Horn Not working on M800 Icon_minitimeby ardie Sat Jun 13, 2020 6:34 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password