Suzuki 800 Intruder Club & Forum
Welcome to suzuki800 Intruder forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, VZ800, VS800, C50, M50, Intruder / Boulevard / Marauder.

You will need to register before all the area's become visible, before doing so please enter & read the first thread in the Introductory area

It will only take a minute to register & it would be great to have you on board
This is a free to access and use site.
Suzuki 800 Intruder Club & Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Suzuki 800 Intruder Club & Forum

A UK Site Dedicated To The Suzuki C800, VL800, VX800, M800, VZ800, VS800, C50, M50 Model Intruder / Boulevard / Marauder
 
HomeRegisterLog in

 

 Horn on M800 stopped working

Go down 
AuthorMessage
ippikin
Member
ippikin


Horn on M800 stopped working Empty
PostSubject: Horn on M800 stopped working   Horn on M800 stopped working Icon_minitimeWed Dec 28, 2011 1:18 am

My horn seems to have stopped working; so I need to test it and the wiring. It looks a pig to remove from behind the radiator; has anyone got any tips?
Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
Mr Intruder


Horn on M800 stopped working Empty
PostSubject: Re: Horn on M800 stopped working   Horn on M800 stopped working Icon_minitimeWed Dec 28, 2011 8:25 am

The horn itself is a bitch to get to, when I installed my Stebel horn I left the stock one in place partly because it was so awkward to get to & just pulled the wires off.
You can still easily test if the actual stock horn is OK or not though by pulling the wires off it and popping them on another one or on to a 12v light. Lots of easy ways to test without using a meter, if something else works off the wires then you know the horn is down.
Back to top Go down
ippikin
Member
ippikin


Horn on M800 stopped working Empty
PostSubject: Thanks!   Horn on M800 stopped working Icon_minitimeWed Dec 28, 2011 9:17 am

Will give it a try!
Back to top Go down
ippikin
Member
ippikin


Horn on M800 stopped working Empty
PostSubject: Horn problems   Horn on M800 stopped working Icon_minitimeWed Dec 28, 2011 11:47 am

Have managed to get the horn out.... you can just about get access from the L side of the bike if you move the radiator hose up out of the way and tie it back. The wiring is fine and there is continuity at the switch, but the horn unit is knackered (what a shame!)
I will not be bothering getting a new stock horn, looking at the Stebel instead.

Dave...... did you hide the relay up under the steering column cover? And what size in-line fuse did you use from the battery?
Back to top Go down
Mr Intruder
Suzuki800.com Founder ... & ... Senior Administrator
Mr Intruder


Horn on M800 stopped working Empty
PostSubject: Re: Horn on M800 stopped working   Horn on M800 stopped working Icon_minitimeWed Dec 28, 2011 2:55 pm

ippikin wrote:
Dave...... did you hide the relay up under the steering column cover? And what size in-line fuse did you use from the battery?
Yeah relay is behind neck cover and I used a 30amp fuse
Have a look in the link in my above post, that should explain a little.
Back to top Go down
captain crash
Mentally Deficient lunatic ..... & ..... Site Moderator
captain crash


Horn on M800 stopped working Empty
PostSubject: Re: Horn on M800 stopped working   Horn on M800 stopped working Icon_minitimeThu Dec 29, 2011 8:30 am

ippikin wrote:
I will not be bothering getting a new stock horn, looking at the Stebel instead.

These horns are cheap and you will be shocked at how loud they are affraid Horn on M800 stopped working 249703
Back to top Go down
Sponsored content




Horn on M800 stopped working Empty
PostSubject: Re: Horn on M800 stopped working   Horn on M800 stopped working Icon_minitime

Back to top Go down
 
Horn on M800 stopped working
Back to top 
Page 1 of 1
 Similar topics
-
» Transaxle stopped working out of nowhere
» bite alarm
» Billy's vs E.T vs Predator Alarms vs Fox Micron P's
» Working overtime again
» Maxxis Big Horn Tire Pressure

Permissions in this forum:You cannot reply to topics in this forum
Suzuki 800 Intruder Club & Forum :: The Garage :: General Electrical Modifications, Help & Information.-
Jump to:  
Slide Show
A random selection of suzuki800.com member bikes.
Latest topics
» Slammed Volusia - 2" lowering kit - video
Horn on M800 stopped working Icon_minitimeby buzz5019 Yesterday at 9:37 pm

» VX800 exhaust advice
Horn on M800 stopped working Icon_minitimeby oldmick Yesterday at 8:05 pm

» Hi everyone
Horn on M800 stopped working Icon_minitimeby stingray Yesterday at 1:57 pm

» Suzuki C50/C800 valve adjustment procedure tips
Horn on M800 stopped working Icon_minitimeby EazyDuz Wed Jul 08, 2020 10:42 pm

» Cooling fan troubles
Horn on M800 stopped working Icon_minitimeby Dushmth88 Wed Jul 08, 2020 7:27 pm

» Debaffled and looking for end caps
Horn on M800 stopped working Icon_minitimeby rehanpk Tue Jul 07, 2020 7:34 pm

» Tail light fuse blowing
Horn on M800 stopped working Icon_minitimeby hmac Tue Jul 07, 2020 1:57 pm

» * Suzuki C800, De-badge *
Horn on M800 stopped working Icon_minitimeby Badger Fri Jul 03, 2020 5:19 pm

» Single red and blue wire help
Horn on M800 stopped working Icon_minitimeby ardie Tue Jun 30, 2020 5:55 pm

» New old guy
Horn on M800 stopped working Icon_minitimeby ardie Tue Jun 30, 2020 5:46 pm

» Hi Suzuki drivers
Horn on M800 stopped working Icon_minitimeby ardie Tue Jun 23, 2020 1:01 am

» Hello
Horn on M800 stopped working Icon_minitimeby Badger Sun Jun 21, 2020 10:51 am

» Lft side swing arm cover - decoration or functional?
Horn on M800 stopped working Icon_minitimeby Badger Sat Jun 20, 2020 12:48 pm

» Advice on carrier needed.
Horn on M800 stopped working Icon_minitimeby Holstein Thu Jun 18, 2020 6:50 pm

» Helllo
Horn on M800 stopped working Icon_minitimeby Badger Thu Jun 18, 2020 10:52 am

» Bad vibrations
Horn on M800 stopped working Icon_minitimeby Badger Tue Jun 16, 2020 1:31 pm

» 50/50 vinegar flush.
Horn on M800 stopped working Icon_minitimeby Badger Mon Jun 15, 2020 2:41 pm

» Vz800 speedometer
Horn on M800 stopped working Icon_minitimeby Mpiercy94 Sun Jun 14, 2020 11:43 am

» Hello
Horn on M800 stopped working Icon_minitimeby Pygsli Sat Jun 13, 2020 7:01 pm

» Front wheel gap?
Horn on M800 stopped working Icon_minitimeby ardie Sat Jun 13, 2020 6:34 pm

Log in
Username:
Password:
Log in automatically: 
:: I forgot my password